package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([0-9]{7}[xX0-9]{1})\_([0-9]{3}|[0-9]{3}\-[0-9]{3})\_([0-9]{2}|[0-9]{2}\-[0-9]{2})\_.*\..*`)
var str = []byte(`23526963_013-014_01-03_s001_text.pdf`)
var substitution = []byte("$1_$2_$3")
var count = 1 // negative counter is equivalent to global case (replace all)
str = re.ReplaceAllStringFunc(str, func(s string) string {
if count == 0 {
return s
}
count -= 1
return re.ReplaceAllString(s, substitution)
})
fmt.Println(string(str))
}