import re
regex = re.compile(r"([0-9]{7}[xX0-9]{1})\_([0-9]{3}|[0-9]{3}\-[0-9]{3})\_([0-9]{2}|[0-9]{2}\-[0-9]{2})\_.*\..*")
test_str = "23526963_013-014_01-03_s001_text.pdf"
subst = "$1_$2_$3"
result = regex.sub(subst, test_str, count=1)
if result:
print(result)