// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)\<\/?v.*?\>").unwrap();
let string = "<v Instructor>We can go back now</v>
to our web server checklist.
We've already seen better ways to organise our code
into reusable pieces with modules,
we've seen ways to deal with files,
both synchronous and asynchronous,
and buffers,
both the built-in Node one
and the ES6 buffers,
and we've seen a way to deal with work";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}