import Foundation
let pattern = #"<\?xml [^?]*\?><(?<root>\w+)>(.*?)<\/\1>\n?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<?xml version="1.0"?><ClientRequest><RequestId>dasdad asdasd asd asd asda sdasd as dasd1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test>
<?xml version="1.0"?><ClientRequest><RequestId>1</RequestId></ClientRequest><?xml version="1.0"?><test><RequestId>1</RequestId></test><?xml version="1.0"?><lol><RequestId>1</lo
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)