#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)core_version_requirement(?:(?!11).)*$"
Local $sString = "core_version_requirement: ^10 || ^11" & @CRLF & _
"core_version_requirement: ^9.1 || 10" & @CRLF & _
"core_version_requirement: 11.1 || 12" & @CRLF & _
"core_version_requirement: ^10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")