$re = '/core_version_requirement(?:(?!11).)*$/m';
$str = 'core_version_requirement: ^10 || ^11
core_version_requirement: ^9.1 || 10
core_version_requirement: 11.1 || 12
core_version_requirement: ^10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);