const regex = /core_version_requirement(?:(?!11).)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('core_version_requirement(?:(?!11).)*$', 'gm')
const str = `core_version_requirement: ^10 || ^11
core_version_requirement: ^9.1 || 10
core_version_requirement: 11.1 || 12
core_version_requirement: ^10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}