re = /core_version_requirement(?:(?!11).)*$/m
str = 'core_version_requirement: ^10 || ^11
core_version_requirement: ^9.1 || 10
core_version_requirement: 11.1 || 12
core_version_requirement: ^10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end