import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "core_version_requirement(?:(?!11).)*$";
final String string = "core_version_requirement: ^10 || ^11\n"
+ "core_version_requirement: ^9.1 || 10\n"
+ "core_version_requirement: 11.1 || 12\n"
+ "core_version_requirement: ^10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}