package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?s)(^|\n)?<form\b.*?<\/form>`)
var str = `<p>Hey I am a boy</p>
<form id='id1' class='class1'>Content</form>
<p>Hey I am a girl</p>
<form id='id1' class='class1'>content</form>`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}