$re = '~(^|\n)?<form\b.*?<\/form>~s';
$str = '<p>Hey I am a boy</p>
<form id=\'id1\' class=\'class1\'>Content</form>
<p>Hey I am a girl</p>
<form id=\'id1\' class=\'class1\'>content</form>';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;