import re
regex = re.compile(r"(^|\n)?<form\b.*?<\/form>", flags=re.DOTALL)
test_str = ("<p>Hey I am a boy</p>\n"
"<form id='id1' class='class1'>Content</form>\n"
"<p>Hey I am a girl</p>\n"
"<form id='id1' class='class1'>content</form>")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)