const regex = /(script)\s(\w*)\s(\w*)\((?:([a-z|A-Z]+)\s\w+)?\)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(script)\\s(\\w*)\\s(\\w*)\\((?:([a-z|A-Z]+)\\s\\w+)?\\)', '')
const str = `script void bar(type foo)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}