re = /(script)\s(\w*)\s(\w*)\((?:([a-z|A-Z]+)\s\w+)?\)/
str = 'script void bar(type foo)'
# Print the match result
str.match(re) do |match|
puts match.to_s
end