$re = '/(script)\s(\w*)\s(\w*)\((?:([a-z|A-Z]+)\s\w+)?\)/';
$str = 'script void bar(type foo)';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);