import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ",(?=(((?!\\)).)*\\()|[^\\(\\)]*$)";
final String string = "off_sls_total numeric(12, 2), off_sls_profit numeric(12, 2), off_sls_profit_percent numeric(12, 2), off_profit numeric(12, 2), off_profit_percent numeric(12, 2)";
final String subst = ",\\n\\t";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}