const regex = new RegExp(',(?=(((?!\\)).)*\\()|[^\\(\\)]*$)', 'g')
const str = `off_sls_total numeric(12, 2), off_sls_profit numeric(12, 2), off_sls_profit_percent numeric(12, 2), off_profit numeric(12, 2), off_profit_percent numeric(12, 2)`;
const subst = `,\n\t`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);