use strict;
my $str = 'off_sls_total numeric(12, 2), off_sls_profit numeric(12, 2), off_sls_profit_percent numeric(12, 2), off_profit numeric(12, 2), off_profit_percent numeric(12, 2)';
my $regex = qr`,(?=(((?!\)).)*\()|[^\(\)]*$)`p;
my $subst = ',\\n\\t';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";