const regex = /({{m(?:\|[^\|]+)*\|\|)([^}]+)(?=}})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('({{m(?:\\|[^\\|]+)*\\|\\|)([^}]+)(?=}})', 'gm')
const str = `{{m|gem-pro|*karzijan?||to turn}}`;
const subst = `$1($2)`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);