$re = '/({{m(?:\|[^\|]+)*\|\|)([^}]+)(?=}})/m';
$str = '{{m|gem-pro|*karzijan?||to turn}}';
$subst = "$1($2)";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;