re = /({{m(?:\|[^\|]+)*\|\|)([^}]+)(?=}})/m
str = '{{m|gem-pro|*karzijan?||to turn}}'
subst = '$1($2)'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result