const regex = /&nb\s*sp;/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('&nb\\s*sp;', 'gm')
const str = `
&nb sp;
&nb sp;
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);