import re
regex = re.compile(r"&nb\s*sp;", flags=re.MULTILINE)
test_str = (" \n"
"&nb sp;\n"
"&nb sp;\n")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)