use strict;
my $str = '
&nb sp;
&nb sp;
';
my $regex = qr/&nb\s*sp;/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";