use strict;
my $str = '.fp-viewing-5
.fp-viewing-5-0
';
my $regex = qr/(\.fp-viewing-\d)/p;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";