import Foundation
let pattern = #"(\.fp-viewing-\d)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
.fp-viewing-5
.fp-viewing-5-0
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)