$re = '/(\.fp-viewing-\d)/';
$str = '.fp-viewing-5
.fp-viewing-5-0
';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;