import re
regex = re.compile(r"(\.fp-viewing-\d)")
test_str = (".fp-viewing-5\n"
".fp-viewing-5-0\n")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)