re = /(\.fp-viewing-\d)/
str = '.fp-viewing-5
.fp-viewing-5-0
'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result