using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(https?:\/\/.*\.(?:png|jpg))";
string input = @"http://sub.domain.com/uploads/files/23-11-2011/234552-574-2321-232/asd.png";
RegexOptions options = RegexOptions.IgnoreCase;
Match m = Regex.Match(input, pattern, options);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}