package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?i)(https?:\/\/.*\.(?:png|jpg))`)
var str = `http://sub.domain.com/uploads/files/23-11-2011/234552-574-2321-232/asd.png`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}