using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-z0-9]+\.?[a-z0-9]+$";
string input = @"f.oo
foo.
f.o.o
fooo
f....
foo.txtasdfasdfasdfasfdasfdasfd
foo
foooo";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}