package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-z0-9]+\.?[a-z0-9]+$`)
var str = `f.oo
foo.
f.o.o
fooo
f....
foo.txtasdfasdfasdfasfdasfdasfd
foo
foooo`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}