import re
regex = re.compile(r"^[a-z0-9]+\.?[a-z0-9]+$", flags=re.MULTILINE)
test_str = ("f.oo\n"
"foo.\n"
"f.o.o\n"
"fooo\n"
"f....\n"
"foo.txtasdfasdfasdfasfdasfdasfd\n"
"foo\n"
"foooo")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")