#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "[^a-zA-Z0-9 ]|((?<![a-zA-Z0-9 ])[a-zA-Z0-9 ]{1,3}(?![a-zA-Z0-9 ]))"
Local $sString = "+«›é¦$6ðbç›4;r6O–0µ<hiñÅÙuµN%\$Õnever in a million yearsþÈWèÃƧÀ[‰võ³°œ»ê"V5n¤ÉÂT‡«" & @CRLF & _
"+1+ sequence one char long" & @CRLF & _
"+12+ sequence two chars long" & @CRLF & _
"+123+ sequence three chars long" & @CRLF & _
"+1234+ sequence four chars long" & @CRLF & _
"+12345+ sequence five chars long" & @CRLF & _
"+123456+ sequence six chars long" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")