const regex = /[^a-zA-Z0-9 ]|((?<![a-zA-Z0-9 ])[a-zA-Z0-9 ]{1,3}(?![a-zA-Z0-9 ]))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[^a-zA-Z0-9 ]|((?<![a-zA-Z0-9 ])[a-zA-Z0-9 ]{1,3}(?![a-zA-Z0-9 ]))', 'g')
const str = `+«›é¦\$6ðbç›4;r6O–0µ<hiñÅÙuµN%\\\$Õnever in a million yearsþÈWèÃƧÀ[‰võ³°œ»ê"V5n¤ÉÂT‡«
+1+ sequence one char long
+12+ sequence two chars long
+123+ sequence three chars long
+1234+ sequence four chars long
+12345+ sequence five chars long
+123456+ sequence six chars long
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}