$re = '/[^a-zA-Z0-9 ]|((?<![a-zA-Z0-9 ])[a-zA-Z0-9 ]{1,3}(?![a-zA-Z0-9 ]))/';
$str = '+«›é¦$6ðbç›4;r6O–0µ<hiñÅÙuµN%\\$Õnever in a million yearsþÈWèÃƧÀ[‰võ³°œ»ê"V5n¤ÉÂT‡«
+1+ sequence one char long
+12+ sequence two chars long
+123+ sequence three chars long
+1234+ sequence four chars long
+12345+ sequence five chars long
+123456+ sequence six chars long
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);