import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^a-zA-Z0-9 ]|((?<![a-zA-Z0-9 ])[a-zA-Z0-9 ]{1,3}(?![a-zA-Z0-9 ]))";
final String string = "+«›é¦$6ðbç›4;r6O–0µ<hiñÅÙuµN%\\$Õnever in a million yearsþÈWèÃƧÀ[‰võ³°œ»ê\"V5n¤ÉÂT‡«\n"
+ "+1+ sequence one char long\n"
+ "+12+ sequence two chars long\n"
+ "+123+ sequence three chars long\n"
+ "+1234+ sequence four chars long\n"
+ "+12345+ sequence five chars long\n"
+ "+123456+ sequence six chars long\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}