use strict;
my $str = '+«›é¦$6ðbç›4;r6O–0µ<hiñÅÙuµN%\\$Õnever in a million yearsþÈWèÃƧÀ[‰võ³°œ»ê"V5n¤ÉÂT‡«
+1+ sequence one char long
+12+ sequence two chars long
+123+ sequence three chars long
+1234+ sequence four chars long
+12345+ sequence five chars long
+123456+ sequence six chars long
';
my $regex = qr/[^a-zA-Z0-9 ]|((?<![a-zA-Z0-9 ])[a-zA-Z0-9 ]{1,3}(?![a-zA-Z0-9 ]))/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}