#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\s*\bSECOND LEVEL\b\n(?:(?!\n\n)[\s\S])*\bDining:\s*(\d+)"
Local $sString = " MAIN LEVEL" & @CRLF & _
" Entrance: 11" & @CRLF & _
" Dining: 33" & @CRLF & _
"" & @CRLF & _
" SECOND LEVEL" & @CRLF & _
" Entrance: 4444" & @CRLF & _
" Living: 5555" & @CRLF & _
" Dining: 666" & @CRLF & _
"" & @CRLF & _
" THIRD LEVEL" & @CRLF & _
" Dining: 999" & @CRLF & _
" Kitchen: 000" & @CRLF & _
" Family: 33332" & @CRLF & _
"" & @CRLF & _
" SECOND LEVEL" & @CRLF & _
" Entrance: 4444" & @CRLF & _
" Living: 5555" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")