$re = '/^\s*\bSECOND LEVEL\b\n(?:(?!\n\n)[\s\S])*\bDining:\s*(\d+)/m';
$str = ' MAIN LEVEL
Entrance: 11
Dining: 33
SECOND LEVEL
Entrance: 4444
Living: 5555
Dining: 666
THIRD LEVEL
Dining: 999
Kitchen: 000
Family: 33332
SECOND LEVEL
Entrance: 4444
Living: 5555
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);