import re
regex = re.compile(r"^\s*\bSECOND LEVEL\b\n(?:(?!\n\n)[\s\S])*\bDining:\s*(\d+)", flags=re.MULTILINE)
test_str = (" MAIN LEVEL\n"
" Entrance: 11\n"
" Dining: 33\n\n"
" SECOND LEVEL\n"
" Entrance: 4444\n"
" Living: 5555\n"
" Dining: 666\n\n"
" THIRD LEVEL\n"
" Dining: 999\n"
" Kitchen: 000\n"
" Family: 33332\n\n"
" SECOND LEVEL\n"
" Entrance: 4444\n"
" Living: 5555\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")