const regex = /^\s*\bSECOND LEVEL\b\n(?:(?!\n\n)[\s\S])*\bDining:\s*(\d+)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\s*\\bSECOND LEVEL\\b\\n(?:(?!\\n\\n)[\\s\\S])*\\bDining:\\s*(\\d+)', 'gm')
const str = ` MAIN LEVEL
Entrance: 11
Dining: 33
SECOND LEVEL
Entrance: 4444
Living: 5555
Dining: 666
THIRD LEVEL
Dining: 999
Kitchen: 000
Family: 33332
SECOND LEVEL
Entrance: 4444
Living: 5555
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}