#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z\d-_]*$"
Local $sString = "my90_testVALIDfile-name" & @CRLF & _
"9invalidFILENAME" & @CRLF & _
"invalid fn90" & @CRLF & _
"valid-name" & @CRLF & _
"validName" & @CRLF & _
"validName2398472-2034" & @CRLF & _
"valid_Name23__345" & @CRLF & _
"800invalid filename" & @CRLF & _
"in&valid" & @CRLF & _
"thisISNOT(VALID)" & @CRLF & _
"this is not valid" & @CRLF & _
"THISISVALID" & @CRLF & _
"_thisIsValid" & @CRLF & _
"-thisisvalid" & @CRLF & _
"d asdf invalid" & @CRLF & _
"123asdfVALID-valid"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")