package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z\d-_]*$`)
var str = `my90_testVALIDfile-name
9invalidFILENAME
invalid fn90
valid-name
validName
validName2398472-2034
valid_Name23__345
800invalid filename
in&valid
thisISNOT(VALID)
this is not valid
THISISVALID
_thisIsValid
-thisisvalid
d asdf invalid
123asdfVALID-valid`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}