using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z\d-_]*$";
string input = @"my90_testVALIDfile-name
9invalidFILENAME
invalid fn90
valid-name
validName
validName2398472-2034
valid_Name23__345
800invalid filename
in&valid
thisISNOT(VALID)
this is not valid
THISISVALID
_thisIsValid
-thisisvalid
d asdf invalid
123asdfVALID-valid";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}