$re = '/^[a-zA-Z\d-_]*$/m';
$str = 'my90_testVALIDfile-name
9invalidFILENAME
invalid fn90
valid-name
validName
validName2398472-2034
valid_Name23__345
800invalid filename
in&valid
thisISNOT(VALID)
this is not valid
THISISVALID
_thisIsValid
-thisisvalid
d asdf invalid
123asdfVALID-valid';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);