import Foundation
let pattern = #"^[a-zA-Z\d-_]*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
my90_testVALIDfile-name
9invalidFILENAME
invalid fn90
valid-name
validName
validName2398472-2034
valid_Name23__345
800invalid filename
in&valid
thisISNOT(VALID)
this is not valid
THISISVALID
_thisIsValid
-thisisvalid
d asdf invalid
123asdfVALID-valid
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)