#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(\bhp\b).*(\blaptop\b)|(\blaptop\b).*(\bhp\b)"
Local $sString = "I have hp laptop" & @CRLF & _
"I have a laptop" & @CRLF & _
"I have laptop made by HP" & @CRLF & _
"I have a fleshpot laptop"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")