$re = '/(\bhp\b).*(\blaptop\b)|(\blaptop\b).*(\bhp\b)/i';
$str = 'I have hp laptop
I have a laptop
I have laptop made by HP
I have a fleshpot laptop';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);